Questo blog e' libero dal NOFOLLOW!

Problemi hard Disk USB esterno.

mercoledì 14 ottobre 2009 scritto da Luigi Vinci Letto 12.786 volte lascia un commento »

hdesternoProblemi con un hard disk esterno auto alimentato, ogni tanto e improvvisamente sparisce da risorse del computer, oppure l’accesso è molto lento, oppure la scrittura non viene permessa.

Hard Disk USB esterno non va? Problema di alimentazione… del PC

[...]

Ringrazio il mio collega, nonché amico Luigi per l’ospitalità nel suo sito.

Premessa: chi scrive è uno sconsiderato che quando vuole conoscere qualcosa, sia per lavoro che per svago, prima di passare in biblioteca, passa in rete: ci tengo inoltre a dire che tutte le prove effettuate erano a mio rischio e pericolo perciò non imitatemi! Piuttosto studiate e laureatevi se volete imparare a connettere un cavo USB! Scrivo questo articolo così com’è, dopo affannose ricerche (online ^_^.), e mi auguro possa essere di aiuto a tutti quelli che come me hanno avuto lo stesso problema ed erano ad un passo dallo buttare un HD (quasi) nuovo.

Dati: i miei possiedono un HD esterno USB della Maxtor (SATA da 2,5″, serie Maxtor Basics Portable codice STM901601EHD301-RK ) da 160 GB con interfaccia USB 2.0 a 480 Mb/s. Questa bella periferica è auto alimentata nel senso che il cavo principale si diparte in 2 cavi che vanno poi connessi entrambi al PC (cioè 2 porte USB occupate). L’hanno utilizzato su un PC per diverso tempo come archivio di dati e l’unico suono che produceva era un delicatissimo ronzio dovuto alla rotazione dei dischi.

Link sponsorizzato

Problema: un giorno ho deciso di portarlo da me per trasferire tutte le foto nel mio potentissimo PC Desktop (dual core, etc. etc.) a prova di crash.

Collego l’HD alle porte USB2 sul retro e con mia grande sorpesa riscontro a più riprese che: non viene riconosciuto dal sistema operativo (SO);  oppure lo riconosce ma dopo un pò non è più presente tra le “risorse del computer”, è lento, non posso eseguire operazioni di lettura/scrittura e quando lo faccio è lentissimo, anche il SO ne risente in termini di performance, può farlo crashare, scatta pesantemente, lampeggia, dà segno di attività incessante del disco all’inverosimile, sembra difettoso, sembra da buttare, è impazzito, NON è frammentato.
Messaggio di errore: “Scrittura rimandata non riuscita impossibile salvare tutti i dati in H:\$Mft … I dati sono andati persi La causa dell’errore potrebbe essere un errore hardware… etc.”

Troubleshooting: lo stacco e lo metto su un portatile Benq del 2005 (serie Joybook S53). Magia! Funziona benissimo, non scatta più, è delicato come una farfalla.
Ricollego al desktop ma nulla. Le provo tutte:
aggiornamento driver (XP non ne ha bisogno); scambio porte USB (ne ho 4 e sono 2.0); utilizzo pannello frontale; sostituzione cavo USB; verifica dei controller della scheda madre (mobo); ricerca conflitti nel SO.
Prendo un tester per misurare la tensione alla porta USB e scopro che questa è insufficiente (di solito +12/+ 5 Volt).

Cause: è presto detto: l’ALI(mentatore) non è sufficiente anche con i suoi 450W perché non supporta variazioni di tensione – dovute a un numero eccessivo di periferiche collegate. Evidentemente l’ALI, tramite la mobo, fa in modo di mantenere la tensione necessaria solo per ciò che serve. O meglio, determinate periferiche possono avere un arco di tolleranza maggiore.

Soluzione: nella mobo avevo due slot PCI impegnati rispettivamente da una porta firewire e una scheda wi-fi. E’ vero non le usavo, ma evidentemente la loro presenza “gravava” (passatemi il termine) sul bilancio globale della macchina, perciò gli ho disinstallati fisicamente e… MAGIA! L’hd ora funziona!

Considerazioni: non so se esistano alimentatori per PC appositi (insomma, sostituire quello che c’è nel PC) capaci di gestire queste variazioni ma credo di sì. ATTENZIONE: si parla di variazioni di tensione “fisiologiche” e NON imputabili alla rete elettrica, ergo la soluzione non può e non potrà essere l’acquisto di un UPS o simili.

Note finali:

  • ho un’HD USB 2.0 della Packard Bell da 500GB alimentato esternamente che stranamente ha dato gli stessi problemi alle condizioni iniziali su menzionate, chissà?
  • un mio amico ha risolto strappando via il case del suo HD esterno e collegando tutto su IDE. C’è da fidarsi?

Spazio vuoto, lo vuoi tu? Contattami ;)
  • John

    E come fai  disattivare qualcosa per risparmiare voltaggio/amperaggio quando ti capita di collegare un box esterno USB ad un portatile?!…  

  • Yanek

    Scusate ma involontariamente ho letto i vostri messaggi, anche a me succedeva la stessa cosa con il mio HD esterno da 750G,ho risolto semplicemente stcollegando e ricollegando il cavo che va dalla porta usb all’HD ….,nn so se è un caso ma funziona sempre e da Dio!!!